Starting Database failed

Topics related to the LSPS Engine and the management of running processes.
Forum rules
Make sure every topic contains information about your LSPS version and if relevant also your server OS, client OS, database name and version, and application server name and version.
User avatar
randy.adkins
 
Posts: 38
Joined: Tue Mar 06, 2012 4:17 pm

Starting Database failed

Sat Mar 02, 2013 2:28 pm

I am getting the strating database failed error when trying to upload a model from the Process Design Suite a LSPS Embedded Launcher Instance. I can export the model and upload it via the Process Management Console on the web and everything works. I have deleted the h2 which dropped and recreated the database, but I am still receiving this error in the Process Design Suite. I am using version 2.6.2. I have included a screen shot of the error and details.

What can I do to allow uploads from the PDS again?
Attachments
Screenshot-Error  .png
Screenshot-Error .png (32.71 KiB) Viewed 6273 times

Maros Bajtos
 
Posts: 145
Joined: Mon Feb 27, 2012 2:52 pm

Re: Starting Database failed

Mon Mar 04, 2013 10:02 am

Randy, this error occurs, when you have your java embedded launcher started and you're using runtime connection for PDS Glassfish embedded server. To overcome the issue, create new runtime connection configuration and use that one instead of the one which is present by default in PDS - you can distinguish between connections by checking "Type" column in "Runtime connection settings" - if the type is "Embedded", PDS will try to start embedded glassfish. If it's "Remote" it will only try to connect to server running on the given url. The error you're receiving is due to the fact, that you have your java embedded server running and PDS is trying to start default embedded glassfish server which tries to initialize database and it fails.

Return to Management

Who is online

Users browsing this forum: No registered users and 1 guest