Migration Tool error

Topics related to the integration of LSPS with external systems.
Forum rules
Make sure every topic contains information about your LSPS version and if relevant also your server OS, client OS, database name and version, and application server name and version.
eric.graham
 
Posts: 58
Joined: Tue May 13, 2014 12:20 pm

Migration Tool error

Mon Jun 16, 2014 9:47 pm

I am working with the Migration Tool (from Ondrej) for the DB2 database. I am trying to run the .sh scripts in Cygwin (on PC) and I am getting an "Error: Could not find or load main class com.whitestein.lsps.dbmigration.DbMigration"
Code: Select all
$ migrate.sh
./lib/db2jcc_license_cu-9.5.jar:./lib/db2jcc-9.5.jar:./lib/flyway-core-2.0.3.jar:./lib/h2-1.3.170.jar:./lib/jtds-1.2.4.jar:./lib/lsps-db-migration-2.7.1410.jar:./lib/mysql-connector-java-5.1.11.jar:./lib/ojdbc6-11.2.0.3.0.jar:./lib/postgresql-8.3-603.jdbc3.jar:./lib/sapdbc-7.4.4.jar:Error: Could not find or load main class com.whitestein.lsps.dbmigration.DbMigration

I am running the script (with ((but not in)) the lib folder) inside the embedded folder. Not sure where I am missing something.

Ondrej Danko
 
Posts: 31
Joined: Mon Feb 27, 2012 1:14 pm

Re: Migration Tool error

Tue Jun 17, 2014 8:33 am

Hi Eric,

migrate.sh is intended for *nix systems. On *nix systems classpath separator is ':', on windows ';'. See e.g. stackoverflow. What you need to do is replace on line 19 in migrate.sh ':' with ';'.

Hope that helps.

eric.graham
 
Posts: 58
Joined: Tue May 13, 2014 12:20 pm

Re: Migration Tool error

Fri Apr 29, 2016 3:38 pm

Hello -
We are trying to migrate from 2.7 to 3.1. I have tried every variation of the LSPS's "Migration from LSPS 2.7 to LSPS 3.0" on https://lspsforum.whitestein.com/viewtopic.php?f=26&t=235 without luck. We are using Windows 7 and as400 BD2 database.

We are migrating our BD2 as400 database. I have copied the bat script listed on the link above "migrate databaseUrl:jdbc:h2:tcp://localhost/h2/h2;MVCC=TRUE;LOCK_TIMEOUT=60000 user:lsps password:lsps initialVersion:2.7.0.010" .

I have replaced all ":" with "=" (with spaces. i.e. var = var, without=without spaces), using the variables, without variables. Used the migrate.bat, windows command, used migrate at beginning of script, migrate.bat, removed it... everything I can think of (same issues). - I am running the script in the "lsps-runtime-3.1.1006\lsps-runtime\db-migration" location. (lib folder is present).

as per the LSPS page, my script I have been working with and changing various ways is:
(user name, serverURL, and password are removed for security and not as is. It would either be i.e. user:thisUser, or I have tried user = thisUser, etc)

migrate databaseUrl:jdbc:as400://serverURL user:myUserName password:myPassWord initialVersion:3.0.0.001

(I also have the jt400 jar file in lib folder just to make sure nothing is missing...)

Either I try something different and get a syntactical error, or the above script only echos (if on) " migrate databaseUrl:jdbc:as400://serverURL user:myUserName password:myPassWord initialVersion:3.0.0.001" over and over non-stop. (or nothing on screen if echo is off).

(p.s. - the last time we migrated from 2.6 to 2.7, Ondrej had to write a custom SQL script to get the migration to work. - Is this going to be a similar issue we are facing here also?)

Thanks


***** UPDATE - I/we have recently received a custom script for our as/400 DB2. (per Whitestein). I am currently working through this. Thank you.

Return to Integration

Who is online

Users browsing this forum: No registered users and 1 guest